USA Toll Free: 1-866-536-6691

World's Largest Forum Dedicated To Lennox Comfort Products| Over 22,000 Posts!
| Helping Lennox Owners & Servicers Everyday!
Visit Our Lennox Parts Store

Service Forum for Lennox HVAC Owners and Servicers.

Lennox
 All Forums
 Repairing and Servicing Lennox Products
 Repairing / Servicing Lennox Air Conditioning
 Compressor runs, blower doesn't
 New Topic  Reply to Topic
 Printer Friendly
Author  Topic Next Topic  

bobdid

2 Posts

Posted - 08/19/2019 :  11:37:05 AM  Show Profile  Reply with Quote
Per the subject, the compress runs, but the blower doesn't even when the thermostat is set to continuous run. My unit is the G23 Q5/6-125-5.

The control board is the White Rodgers Surefire. 50A62-120. The ACB Low spade connector shows no voltage. I suspect a burned out relay contact. While I await the replacement board I've ordered, is there a way I can bypass this connector with the red wire that connects to it? If so what should the voltage be?

bobdid

2 Posts

Posted - 08/19/2019 :  12:29:27 PM  Show Profile  Reply with Quote
The ACB cool terminal also shows no voltage.
Go to Top of Page
   Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
Lennox HVAC Owners and Servicers Community Forum © 2002-2018 CozyParts.com, Inc Go To Top Of Page
This page was generated in 0.03 seconds. Snitz Forums 2000

Please Choose Your Destination

Never Forget to Change Your Filter Again!
Get Your
FREE
Reminder
Account
We Can Send You an
Email Reminder!
Lennox

CozyParts.com, Inc. is an
Independent Lennox Dealer

Facebook Contact Google+
CozyParts - 2020 East Macarthur ST. Shawnee, OK 74804 | Phone: 1-866-536-6691